Announcement

Collapse
No announcement yet.

Is my OBC Dead?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • jht3
    replied
    that was going to be my first guess. it wasn't plugged in! isnt it nice when things are simple

    Leave a comment:


  • Brendan
    replied
    Just wanted to update with the resolution. I took apart the dash, and found that the OBC harness that's supposed to connect to the back of the instrument cluster was unplugged. I plugged it in, now everything's good to go.

    Leave a comment:


  • Brendan
    replied
    Does anyone know what pins for the OBC connector I should be getting Voltage On? Also, should I be able to start the car with the OBC unplugged? I thought the OBC controlled power to the Main Relay, yet I'm able to start the car fine with it removed.

    So far, I think I tested every pin on the connector, no voltage anywhere with the ignition at the run position, with the running lights for the car turned on. Anyone have any guesses what I'm dealing with here?

    Any insight would be appreciated...

    Leave a comment:


  • Brendan
    replied
    Thanks Graeme, I'll see if that matches up enough for me to figure things out. Nobody has a 88 wiring diagram by chance do they? I'm waiting for my hard copy from KMS right now...

    Also, fwiw, the fuses had no effect.

    - Brendan

    Leave a comment:


  • d2a4
    replied
    I am watching this thread. My OBC also blank.

    Leave a comment:


  • GraemeD
    replied
    Try this: Wiring Manual ETM

    it should help

    Leave a comment:


  • Brendan
    started a topic Is my OBC Dead?

    Is my OBC Dead?

    So I picked up my brand new (to me) 88 M3 this past weekend, and I immediately dove into fixing things. First up, the OBC is completely blank, not working, acting like its dead.

    I first thought this was going to be the light bar in back of the display, but I pulled it, and hooked it up to an external battery, and the lights still work. I also checked out the light bulb that backlights the buttons, and that looks fine, although I didn't test it.

    I currently have 4 fuses out of the car that I've read are related to the OBC, and am going to try reinstalling shortly to see if it makes a difference, but anyone have any ideas? Anyone have a wiring diagram I can use to start testing with my multimeter?

    TIA,
    Brendan
Working...
X