Announcement

Collapse
No announcement yet.

OBC issues

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • OBC issues

    OK A few years ago my OBC started to work intermittently. The temperature and the clock always worked fine but the mpg, mph, avg mpg would have 4 ---- marks and you would get no readings from those. The range readout normally will reset itself when you filled up but then after that you would get the same random reading till you filled the tank up again. I just bought a used OBC with the right code plug in it and it is doing the same thing. Clearly it is not a fuse and I guess it is not the OBC so my conclusion is what ever sensor sends the information to the OBC is where the problem is at. My question is where does the OBC get the information for the AVG MPG, AVG MPH, MPH, RANGE?

  • #2
    Also my speedo and odo have always worked. I replaced the si board but I think the new one had old batteries because if it sits for a month or so the batteries have to get charged up before the tach works.

    Comment


    • #3
      speed sensor?? only part that I can think of...
      1990 e30 m3

      Comment


      • #4
        It seems like the speedo would be broken then but as far as I know it works fine.

        Comment


        • #5
          I pulled the fuse in 21 and it reset the computer and now instead of the range giving me a random number it just has ---M there also when I hit the 1 and 1000 buttons it shows0.0l in the tank and that feature always used to work.

          Comment


          • #6
            I went and filled the tank up and the range number reset itself to 325+ then I checked the liters in the tank by presing the 1 and 1000 buttons. It said there was 48.5 liters which only converts to 12.8 gallons.I know the tank was full because the pump decided not to shut off and gas was blowing out the nozzel.Isn't the tank supposed to hold 14.5 gallons?

            Comment


            • #7
              i am having the same thing, my obc will work sometimes and display the mpg and mph and then sometimes it won't . did you ever fixed yours? i know this is and old post but maybe you can shed some light on this problem

              Comment


              • #8
                OBC question.
                I have the OBC reading metric, and in the past I have had it reading in either metric or English units, but now I can't convert it from metric to English. I've tried pushing all the buttons but nothing works. What's the secret?
                Larry

                Comment


                • #9
                  Press the reset button that has to be pressed with a pen down on the bottom then press the button for you mpg untill it says MPG in the display, then I think you have to hit the set so it saves that setting. william

                  Comment


                  • #10
                    Hi, William,
                    Thanks. I'll try that.
                    Larry

                    Comment


                    • #11
                      Hi, again, William.
                      I did try what you suggested, and it worked.
                      Thanks, Larry

                      Comment

                      Working...
                      X