Announcement

Collapse
No announcement yet.

Oil in spark plugs... cause?

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • JaredwS
    started a topic Oil in spark plugs... cause?

    Oil in spark plugs... cause?

    When I took the car into the shop they found oil in the aprk plugs, maily in #3. When I had my valves adjusted about 5k miles ago the mech found the same thing. He replaced the valve cover gasket at the time (so the invoice says). The mech earlier this week said I would need to replace the valve cover gasket to solve the oil in the spark plugs problem.

    My question is; Is the valve cover gasket the source of this problem? or could it be something else? Thanks.

    -Jared

  • racer8at4heart
    replied
    Originally posted by Mick View Post
    My guess is that this is caused by the O rings between the cam carrier and the head. #6 here
    http://www.realoem.com/bmw/showparts...59&hg=11&fg=15

    You're on the right track though. Replace the cam cover gaskets first, since that's cheap and easy. If that doesn't do it the problem is the cam tray O ring. Not nearly as easy of a fix as the cam cover gasket.
    couldn't have said it better myself

    Leave a comment:


  • alchemist88
    replied
    Any result on changing those gaskets? I realize it was awhile ago but I just dredged up this thread because I found a bunch of oil in two of my plugs. Did you end up changing the o-rings?

    Leave a comment:


  • ///Mflossin
    replied
    I agree with Mick. I think it's more likely to be those o-rings but the gaskets are def worth a shot since they are cheap and easy.

    Leave a comment:


  • Mick
    replied
    My guess is that this is caused by the O rings between the cam carrier and the head. #6 here
    http://www.realoem.com/bmw/showparts...59&hg=11&fg=15

    You're on the right track though. Replace the cam cover gaskets first, since that's cheap and easy. If that doesn't do it the problem is the cam tray O ring. Not nearly as easy of a fix as the cam cover gasket.

    Leave a comment:


  • UweM3
    replied
    I re-use the gaskets for several times and apply a thin layer of clear silicone. Just make sure you put the spark plug gaskets in the same way you took them out.

    Leave a comment:


  • JaredwS
    replied
    Yeah, I think the valve cover gasket from BavAuto comes with those too. So I would change them out as well. Anyone know what, if any kind of sealent is used when changing out gaskets?

    Leave a comment:


  • wld_tony
    replied
    Make sure your tech changes the sparkplug gaskets also, If you look on the diagram Part # 3, those are more likely your culprit.
    http://www.realoem.com/bmw/showparts...60&hg=11&fg=15

    Leave a comment:

Working...
X