Announcement

Collapse

Session time has been extended...

Instead of 30 minutes, you will be logged into s14.net for 1.5 hours of inactivity before being logged-out. Also instead of having only 30 minutes to edit a post, it has now been extended to 60 minutes.
See more
See less

S14 with life of its own, then no start

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • S14 with life of its own, then no start

    Arrgh..
    Engine runs steady at 900rpm idle , and will do so indefinitely.
    But then will suddenly without provocation fish between 1900 and 2500rpm , erratic / quick successions .

    Some times it will return to normal, and contine unphased.
    Others it will not.
    If i kill ignition when it has the erraric idle, i cannot start it again.
    Smells very heavy with fuel on turnover.

    But will spring to life again if left long enough.

    Problem happens from cold or hot, after long or short drive.

    Please any assistance is golden.
    Thanks
    Andrew
    I thank god for every day i'm on this earth,
    with an E30M3

  • #2
    Ok, search helped..
    Please can anyone confirm the CTS for the ecu is the 2 pin sensor , pn 13621709967
    I thank god for every day i'm on this earth,
    with an E30M3

    Comment


    • #3
      Sensor changed.
      The old sensor measured very similar to the 3 new ones i bought to test.
      So not overly confident it's that, but will report after a prolonged testing period.
      I thank god for every day i'm on this earth,
      with an E30M3

      Comment


      • #4
        Andy, I had a nightmare caused by two bad Bosch CTS. Original one failed and the new OE replacement failed as well but not initially. Symptoms were as you described, erractic high idle and eventual flooding which caused a no start condition. Clean plugs solved the symptom but not the problem. A new CTS is a good start but keep an eye on it and check the resistance at different temps to make sure they are within range for that temperature. My mistake was measuring the new TPS once and calling it good without giving it a second thought.
        Last edited by Reelizmpro; 04-15-2016, 12:41 PM.

        88 M3 - LACHSSILBER/M TECH
        89 M3 - ALPINEWEISS II/SCHWARZ
        85 323I S52 - ALPINEWEISS/SCHWARZ
        91 M TECHNIC TURBO - MACAOBLAU/M TECH


        Comment


        • #5
          Hi! Thanks for responding,
          I read i beleive your post on the cts , which was why i bought 3 to test,
          Normal room temp at 1900-2000ohms , 40degr. Cel. at 800 ohms
          But the problem was periodic, so a good measurement of the oe sensor wouldnt be 100% definitive.
          Ill have to wait until it happens again..
          But thank you for helping me,
          Regards Andrew
          I thank god for every day i'm on this earth,
          with an E30M3

          Comment


          • #6
            Sorry late into this thread, obviously you figured out to point your finger at the CTS, but please do not discount the wiring back to the ECU that goes to the CTS.
            One thing that will start happening more and more often in these cars as they get older is these nearing on 30 year old engine harnesses will start to potentially become a problem area.
            Especially on that right side of the engine near the header. If you replace and its still doing it meter out those CTS pins back to the mass connector on the ECU
            jimmy p.
            87 E30 M3 Prodrive British Touring Car
            88 E30 M3 Zinnoberot - Street
            88 E30 M3 Lachsilber - Race (#98 SCCA SPU)
            92 E30 M Technic Cabrio - S14 POWERED!
            98 318Ti M44, Base - Morea Green
            04 Ford F350 - V10

            Comment


            • #7
              Hi Jimmy, thank you!
              Yes i will have a look if needed , but i hope not.. I have having to pull stuff apart.
              The manual states (1364-1 picture number) pin 13 from ecu to cts.
              So ill have a fish about from the plug and see if there is matching resistance to mass.
              Thanks again guys
              I thank god for every day i'm on this earth,
              with an E30M3

              Comment


              • #8
                Just un update,
                The CTS did fix the issue, and since change has not happened again
                I thank god for every day i'm on this earth,
                with an E30M3

                Comment

                Working...
                X