Announcement

Collapse
No announcement yet.

Motor swap thread

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • #91
    These are brand new from BMW. It sucks that the quality of OE parts has fallen off so badly. I've been replacing a lot of parts and for each I pause and consider whether I want to risk running a 30 yr old part or replace it with a new one of questionable quality.

    I guess I'll order some Vibra-Technics street mounts.

    Comment


    • #92
      Engine bay is complete. Don't hate on the factory plug wire loom, I understand the tradeoff. I wanted it to appear OEM withe the exception of the airbox. The barro sensor has been gutted. It's only used it to have someplace neat to store the connector. Only thing left is to install the exhaust and fire it up.









      VSR Dual Cat + Stromung

      Comment


      • #93
        Wow, excellent work Mick -- looks beautiful!!

        Comment


        • #94
          Wow thats exciting. Great work.
          jimmy p.
          87 E30 M3 Prodrive British Touring Car
          88 E30 M3 Zinnoberot - Street
          88 E30 M3 Lachsilber - Race (#98 SCCA SPU)
          92 E30 M Technic Cabrio - S14 POWERED!
          98 318Ti M44, Base - Morea Green
          04 Ford F350 - V10

          Comment


          • #95
            Looks great Mick...like a brand new car...

            I too still have the stock plug wire loom, so no eyebrows are raised during the visual portion of the smog check in the People's Republic of Kalifornia.

            Comment


            • #96
              Originally posted by Mick View Post
              Dealt with my front harness this week. Re-wrapped and new connectors. The old connectors were so brittle they disintegrated when I tried to take them apart.





              Mick,

              Did you replace the 2.5mm leads going into the connector as well or just the connector? I'm tacking the engine harness on mine and trying to figure out how much splicing vs depinning to do

              Thanks!

              Comment


              • #97
                I didn't have to replace any of my leads. They seemed to clean up ok. The boots were still soft and terminals were suprisingly clean.

                Comment


                • #98
                  Looks great, did you manage to find the part number for those white cable clamps above? I presume they are the ones round the front right strut tower.... if they are they are the same as the handbrake cable ones on the rear sway bar links

                  Comment


                  • #99
                    I never did find it. I think the one in the rear that you're referring to is 34411154158, which retains the e-brake cable. If so that one is a little different.
                    https://www.pelicanparts.com/More_In...-1-154-158-BOE

                    Comment


                    • Sorry, i think its these, i got the two mixed up as they look similar and i removed them at the same time

                      16131177494

                      Comment


                      • Yes, that's it. Thank you.

                        Comment

                        Working...
                        X