Announcement

Collapse
No announcement yet.

Idle issue (lean)

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Idle issue (lean)

    Hi,
    I looked on the forum who has already had the problem. It was helpful but I haven't solved it.
    i have airbox with alpha n
    for some time (after a tuning I think) I have very lean idle up to 20: 1 for the rest of the laps the car is very good

    ecu and eprom: I tried to change both but not change
    air leak: there are none (test with leak spry)
    new lambda sensor
    fuel pressure ok
    new battery
    cap, spark plug wires and distributor 1000 km and not problem
    water sensor (blue one) ok
    tps ok
    alpha n connectors with ecu all ok
    baro sensor ok (if I disconnect nothing changes)

    the only thing I noticed is that by disconnecting the air sensor on the airbox
    it seems to go better and the idle is more rich. (12-13: 1)
    I changed the air sensor with new one but not change
    Thanks in advance
    Luca

  • #2
    Check your throttle cable bracket, cable tension, & throttle pedal bracket bushings.
    Confirm TPS idle alignment position on the MAXX software. It should show the Green dot between the 2 yellow arrows.

    I had a very similar issue last year and it was due the throttle pedal not returning to the exact same location. The bushings were almost gone and the cable would stretch, causing the TPS to drift low causing lean condition.

    Comment


    • #3

      Turning the tps (clockwise) the mixture becomes rich and regular idl. I believe that if there was a lair leak it would remain. or i m wrong?
      doing a search I noticed that the tps sensor in question (402) is not easily available and expensive also
      do you have information about a replacement (with different p / n)?
      thanks​​

      Comment


      • #4
        Originally posted by lucam3evo2 View Post
        Turning the tps (clockwise) the mixture becomes rich and regular idl. I believe that if there was a lair leak it would remain. or i m wrong?
        doing a search I noticed that the tps sensor in question (402) is not easily available and expensive also
        do you have information about a replacement (with different p / n)?
        thanks​​
        You can use an S54 TPS with the machined spacer bracket.

        T

        Comment


        • #5
          Originally posted by HANDBLT View Post

          You can use an S54 TPS with the machined spacer bracket.

          T
          would you have photos and / or measurements of the spacer? or can you buy it?
          thanks

          Comment


          • #6
            I bought mine from Lee (Massive) Vuong, maybe shoot him a PM or email?

            pics here: https://www.bmw2002faq.com/forums/to...ve-re-tps-s14/
            1988 M3
            2007 Lotus Exige S

            Comment


            • #7
              hi,
              Do you have a link of Massive?
              i can't find a direct link
              thnaks

              Comment

              Working...
              X