Announcement

Collapse
No announcement yet.

oil pressure light on again

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • oil pressure light on again

    I replaced my oil pressure sending switch last May because the oil light was coming on. It was sort of dim and would go on and off. The new switch fixed the problem. But I'll be damned if the light didn't stay on this afternoon after I started her up. This time it is bright red and always on.

    I didn't attempt to drive her or even let the engine warm up. But after start-up, I got the usual chain slap for the first few seconds then she quieted right down like she always does. I also tried wiggling the connector on the switch, but that didn't work. Oil level is fine.

    Any thoughts? What are the chance the sending switch would go bad after less than a year?
    Last edited by kristoj; 03-30-2007, 11:00 AM.
    '89 Cinnabar Red
    '88 Porsche Carrera Cabriolet
    '82 Fiat Spider Turbo
    '00 Ducati Monster

  • #2
    Originally posted by kristoj View Post
    What are the chance the sending switch would go bad after less than a year?
    Has been known.

    Schwarz 1990 Sport Evolution

    Comment


    • #3
      Swap it out with a bushing and an Autometer 30 pound unit. The stock one only comes on AFTER the bearings are toast. I've had mine in for a few years with no problems.

      TIME TO UPGRADE!!!

      Check this thread for the part #.
      http://www.s14.net/forums/showthread...ht=idiot+light

      or here.

      http://hp.autometer.com/products/acc...d_senders.html

      Comment


      • #4
        definitely check with an oil pressure gauge somehow before driving

        I've always had mech oil press gauges in my cars. In my 320 I was driving home and gauge read low even while driving. Pulled over immediately. At idle it still showed like 14 pounds and would barely hold anything over that when touching the throttle lightly. I coasted it down the hill to my parking spot, then tore down the motor on a weekend. Oil pump was worn out, and 3 of the rod bearings were scored pretty bad.

        Keep a gauge installed and follow what others have done by swapping out the sensor for the idiot light. I also use the 30psi switch and a vdo gauge.

        http://rides.webshots.com/photo/2537...53428890SysgMp

        useful driver vent
        http://rides.webshots.com/photo/2087...53428890DzzLYM

        :headspin:
        Photos

        Comment


        • #5
          Just ordered the 30# switch. I won't be driving it until in arrives.
          '89 Cinnabar Red
          '88 Porsche Carrera Cabriolet
          '82 Fiat Spider Turbo
          '00 Ducati Monster

          Comment

          Working...
          X