Announcement

Collapse
No announcement yet.

Will not start after a simple VR replacement

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Will not start after a simple VR replacement

    Replaced Voltage Regulator. Did not notice wire to D+ was cut so battery was not charging. I had a charge while T/S lights with some workmates. So had a jump and car died on freeway on way home. T/S alternator and VR and purchase new battery. Test alternator with Kragens, it passed. All connections OK now car won't start. Lights and others work. Is there a Fusible Link on a M3 like other E30's? Any main fuse I should check? Anything i missed? Part numbers????? Let me know if you require any info to go on....:thank you
    Lawrence

    BMW CCA San Diego Chapter #192742
    '90 M3 AWII - Garage Queen
    '09 540i Touring 6 Spd - Son's DD
    '03 530i 5 Spd - SO's DD
    '03 Nissan Frontier Crew Cab - My DD & Range truck
    '05 330i ZHP 6 Spd - Alternate DD
    '15 Honda Pilot - Daughter's & Grandkids Hauler

  • #2
    It cranks. Right? Do you have fuel? Spark?


    [email protected]

    1969 2002 racecar
    1989 M3 racecar
    e39 Touring

    Comment


    • #3
      It cranks, but will not fire up. Fuel is available (half tank). New plugs. [I]t did start before running on battery only. Even went to Kragens with alternator not charging battery until I connected all wires properly. Then....no go!!
      Lawrence

      BMW CCA San Diego Chapter #192742
      '90 M3 AWII - Garage Queen
      '09 540i Touring 6 Spd - Son's DD
      '03 530i 5 Spd - SO's DD
      '03 Nissan Frontier Crew Cab - My DD & Range truck
      '05 330i ZHP 6 Spd - Alternate DD
      '15 Honda Pilot - Daughter's & Grandkids Hauler

      Comment


      • #4
        Check the simple things first. Check for spark. If you have spark, check for fuel. Check that all wires under the hood are connected. AFM, Coil, etc.

        If you don't have spark, check the two sensors on the transmission bell housing with a multimeter per the Bently manual. If one of these sensors are bad, the engine will not start. Harness connector for these two sensors is behind the black plastic cover under the hood on the firewall.

        Hate to say it, but you might have fryed the ECU. If you were not sure how to hook the Alt back up there is a chance you might have shorted something out. Hopefully this is not the case since an ECU is big dollars.
        E30 M3 / E46 M3 / E83 X3

        Comment


        • #5
          Hi Das Boot. What I meant by having fuel, isn't if there's fuel in the tank, but if fuel is pressurized to the injectors. Open a fuel line and crank the engine. Is fuel coming?


          [email protected]

          1969 2002 racecar
          1989 M3 racecar
          e39 Touring

          Comment


          • #6
            Is this related to the Fuel Pump Relay or Main Relay? Which /where are these relays located? How to check for voltage if the relays are getting appropriate voltage?? This thread is also probably related to the M3 that died.
            Lawrence

            BMW CCA San Diego Chapter #192742
            '90 M3 AWII - Garage Queen
            '09 540i Touring 6 Spd - Son's DD
            '03 530i 5 Spd - SO's DD
            '03 Nissan Frontier Crew Cab - My DD & Range truck
            '05 330i ZHP 6 Spd - Alternate DD
            '15 Honda Pilot - Daughter's & Grandkids Hauler

            Comment

            Working...
            X