Announcement

Collapse
No announcement yet.

Rough motor, loss of power?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • #16
    spray some water mist with one of those plant sprayers you'd normally keep in the living room when you go into that dark garage in order to 'trigger' the sparks.

    Comment


    • #17
      Thx Thomas, WD40 now liberally sprayed on all relevant parts! - Andy

      Comment


      • #18
        A BIG thanks to Dave (EvadM3) for taking a whole day out of his weekend to come and have look at the car! And boy it was a miserable day yesterday to be going anywhere!

        Distributor cap, coil, plugs, regulator changed (Dave supplied the latter two so extra thanks there!!!). Clearances checked and shims changed!

        Haven't been out in the car yet so can confirm if anything's got better.

        One thing Dave did comment on is that the main pump (Dave pls correct me if I've misunderstood!) runs for like 6 or 7 seconds when turning the ignition on. It does this both from a cold start and warm start...Dave's thinking was that perhaps the in tank pump may have failed...anyone have any thoughts to offer?

        Quite happy to get a replacement in tank pump sorted but wondering if I should perhaps change the out of tank pump and/or the fuel filter whilst I'm at it?

        Thx - Andy

        Comment


        • #19
          Before I forget, a bit more information in case it helps, Dave did a couple more tests....

          Compression Test - Cold - 1 - 185psi (first cylinder tested), 2,3,4 - 180psi

          Vacuum Test (??) - All 4 looking pretty equal IIRC

          - Andy

          Comment


          • #20
            If there are no records of the intake pump being changed in its life then its probably a good idea to change it and the filter.

            Jake

            Comment


            • #21
              Hi Jake,

              When you say the intake pump do you mean the one in tank or the one positioned near the rear wheel?

              Thx

              - Andy

              Originally posted by Jake View Post
              If there are no records of the intake pump being changed in its life then its probably a good idea to change it and the filter.

              Jake

              Comment

              Working...
              X