Announcement

Collapse
No announcement yet.

Lights on Instrument Cluster.

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • ColinM
    replied
    Perhaps the bulb has burned out?

    Leave a comment:


  • Gator18
    replied
    Thanks for the replies.

    My question though, is that recently I DON'T get the lights anymore, when i used to. Is it normal to not have to blip the throttle anymore?

    Leave a comment:


  • kishg
    replied
    mine does it too.. it's normal.

    Leave a comment:


  • ///Empowered
    replied
    I'll try to offer a brief explanation...however I am not an engineer...so this may not be completely accurate.

    First, my M3 does that also. The couple cluster idiot lights stay on till I blip the throttle which in turn gets the alternator spinning fast enough to trigger the excitor wire. The excitor wire is the trigger for the alternator to kick in and begin making juice. (Not OJ kids).

    Now for the thoery of why our cars do this. I've heard two reasons.

    1. Because our engines rev soooo high, the M boys had to use a larger diameter alternator pulley so that the alternator would not implode when we are screaming along at 7800 rpms.

    2. Because our engines have individual throttle bodies and no cold start valve with 1980s Bosch technology, the motronics system is not able to be programmed to blip the throttle on start up like that of other BMW engines.

    Hope that helps.

    Mark M

    Leave a comment:


  • fritzjuan
    replied
    Mine does that too... I think its the abs light, brake lining lights, etc... just rev it a couple of times..

    Leave a comment:


  • Gator18
    replied
    ?

    My M3 used to do this, where I would blip the throttle to ge the lights to go out.

    Just recently, it went away, and I don't need to blid the throttle anymore because the lights don't come on dim. Did it fix itself, or is something else wrong?

    Thanks.

    Leave a comment:


  • Kevin
    replied
    Oh right, if it is that the lights don't go out until you raise the revs then it completely normal as the alternator kick in until the revs reach a specific level. Can't remember what it is now.

    I had read your first post as the lights can on again.

    Leave a comment:


  • audibm
    replied
    The lights will go off when you blip the accelerator. Typical problem to some.

    audibm

    Leave a comment:


  • Kevin
    replied
    It's a bit difficult to offer any advise if you can't tell us what lights you are referrinng to........

    Leave a comment:


  • Hamik
    replied
    Cluster

    Leave a comment:


  • UofOm3
    replied
    lights in the overhead check pannel? in the instrument cluster?? please define...

    Leave a comment:


  • Hamik
    started a topic Lights on Instrument Cluster.

    Lights on Instrument Cluster.

    This came up a while ago but I dont know what happend. When I start up the Car the three lights(too lazy to go and check which ones they are) come up when the car is cold. Is it possible that the cold start switch/valve is the problem? I remember that the car didn't do that when I first got it but it has began to do it and I dont like it. Any Advise ???
Working...
X