Announcement

Collapse
No announcement yet.

User Profile

Collapse

Profile Sidebar

Collapse
Dave @nz
Dave @nz
Registered
Last Activity: Today, 04:43 PM
Joined: 03-31-2009
Location: New Zealand
  • Filter
  • Time
  • Show
  • Source
Clear All
new posts

  • Dave @nz
    replied to Temperature guage
    I think Ron has the answer usually the problem is with the retaining screws slightly loose or the connections, either way some internet research should show how to test the gauge....
    See more | Go to post

    Leave a comment:


  • Dave @nz
    replied to NEW FACTORY E30 M3 Body Shell For Sale
    Does anyone have the original photo of the the three new body shells together which I suspect this for sale post to is from, I remember looking at it back in the day but now would like to add it to my...
    See more | Go to post

    Leave a comment:


  • Dave @nz
    replied to S14B20 O2 sensor
    Hi Juan,
    I think probably the best first step is to check the tuning and address any known issues just go through everything, absolute last thing would be adjust the FQS switch position in the DME....
    See more | Go to post

    Leave a comment:


  • Dave @nz
    replied to M3 number 2.....
    Great to see you removing brackets to clean up behind them then reinstalling them, you made a big improvement to the wiring harness rewrapping it and would be quite satisfying getting it back in the chassi,...
    See more | Go to post

    Leave a comment:

No activity results to display
Show More
Working...
X